• Dear forum reader,
    To actively participate in our forum discussions or to start your own threads, in addition to your game account you need a forum account. You can
    REGISTER HERE!
    Please ensure a translation in to English is provided if your post is not in English and to respect your fellow players when posting.
  • We are looking for you!
    Always wanted to join our Support or Forum Team? We are looking for enthusiastic moderators!
    Take a look at our recruitment page for more information and how you can apply:
    Apply
  • Forum Contests

    Don't forget to check out the current contests here.

Fixed: Road connection bug

DeletedUser115272

Happened twice today. When I moved my Champion Retreat to other part of the city, it showed that there is no road connection where there obviously is. I tried to relog and it seemed to fix itself, only to find out that it bugged out again. I'm playing on mobile, eu.foe, Brisgard. Photo attached
 

Attachments

DeletedUser110603

Happened twice today. When I moved my Champion Retreat to other part of the city, it showed that there is no road connection where there obviously is. I tried to relog and it seemed to fix itself, only to find out that it bugged out again. I'm playing on mobile, eu.foe, Brisgard. Photo attached
Could you please ensure your app version is upto date (latest version is 1.167.2) and check this again? it shouldn't be appearing in this version.
Thankyou
 

DeletedUser115272

Could you please ensure your app version is upto date (latest version is 1.167.2) and check this again? it shouldn't be appearing in this version.
Thankyou
All fine now. Thanksalot