• Dear forum reader,
    To actively participate in our forum discussions or to start your own threads, in addition to your game account you need a forum account. You can
    Please ensure a translation in to English is provided if your post is not in English and to respect your fellow players when posting.
  • We are looking for you!
    Always wanted to join our Support or Forum Team? We are looking for enthusiastic moderators!
    Take a look at our recruitment page for more information and how you can apply:
  • Fall Event 2021

    Calling all Bakers! Read all about the Fall Event 2021 here!
  • Forum Contests

    Do you want to win great prizes? Don't forget to check out the current contest here.

Unable to access Guild Expedition in Brisgard (again!)

  • Thread starter DeletedUser9061
  • Start date


  • World: Brisgard (en2)
  • Browser and Version: Chrome 52.0.2743.116 (64-bit)
  • Overview of the bug: I can't access the Guild Expedition - it is clouded out. This has happened at least twice before!
  • Screenshots: No, sorry.
  • How often this occurs: Always at the moment
  • Urgency: Urgent.
  • Preventative Actions: Tried re-starting browser.
  • Summary: Cannot access GE on Brisgard.
  • I have performed a quicksearch of the forums using a select few keywords relating to my bug to see if it has already been reported: Yes.
  • Have you tried fixing it by using these methods?: Some of them, yes.


Same here in Fel :(
-fog not lifted, timer say's "Starts in 6d 23:15:50h "
(ps - tried on mobile and got same problem )


We are aware of this lag of being able to get into GE for the first hour when it first starts each week, it is currently being investigated.


Going to GE - which I did earlier today and had few fights is ok on Noarsil.
But ... Once I go GE, start battle window, click "Attack", then get "Internal Error".
Earlier today it was still working, so this becomes worse.
Retried several times, re-loaded game, changed troops, all the same - still "Internal Error"