• Dear forum reader,
    To actively participate in our forum discussions or to start your own threads, in addition to your game account you need a forum account. You can
    REGISTER HERE!
    Please ensure a translation in to English is provided if your post is not in English and to respect your fellow players when posting.
  • We are looking for you!
    Always wanted to join our Support or Forum Team? We are looking for enthusiastic moderators!
    Take a look at our recruitment page for more information and how you can apply:
    Apply
  • Fall Event 2021


    Calling all Bakers! Read all about the Fall Event 2021 here!
  • Forum Contests

    Do you want to win great prizes? Don't forget to check out the current contest here.

Some weird issues with timers on the app

DeletedUser111866

World: F and P (once in each)
App version: 1.139.0
Overview: Sometimes the app shows incorrect ETA counters on some of the production buildings. Server side they have completed production, client side some of the buildings display an ETA. Today at 07:05AM MST I've set my 5 blacksmiths in F to 1h production due to DC (have to notice that they are not normally running any production and instead stay uncollected), at 08:09AM I checked the app and found out that one of the blacksmiths displayed finished production with a star, while 4 others were not, I've checked ETA on one of those and it said 18:52 left. I did a reload and bam, all 4 blacksmiths have in fact completed production, and all were not motivated. Before I've hit the same issue in P with six butchers set to 24h, four were finished (three motivated one not) and one of the other two stated it has 2:50:xx left of production - but it couldn't be, as I was collecting late at night that time, so 2:50:00 forward last day (aka 21:10:00 back) I was fast asleep. I did a reload on the app, and those two remaining butchers were in fact also finished.
Screenshots: Well, the screen looks as if nothing happened, say blacksmiths are displayed with ongoing counters with some ETA, de facto the production is already finished, so not attaching any
How often this occurs: Rarely (so far twice in this week), probably is related to the fact I don't unload the app while my device is asleep.
Urgency: Minor
Preventative actions: Reload fixes the issue if it manifests, but man, it should not be there in the first case!
Summary: Sometimes (twice in the last week, at least) the app does not properly update *some* of the production timers.
I have tried searching: Yes, didn't search deep tho, as there were no problems with timers for 5 previous versions (in fact never in this year).
Common fixes tried: Yes, reloading the app works perfectly. Still, WTF?
Hardware info: Samsung Galaxy tab 4, Android stock version 4.4.2.

Proposed detection:
1) Build 20+ blacksmiths;
2) Set all of them rapidly to 1h (doubt the issue will appear with lesser intervals) with app;
3) Set an alarm to 1h00 forward;
4) Confirm it started by tapping the last blacksmith set to production;
5) Minimize the app (I used home button), then turn off the device's screen (short tap on power with Android devices)
6) Wait for alarm, launch the app from home screen, check blacksmiths. Best if your account would get some of those blacksmiths motivated, maybe this affects the issue.
 

Vesiger

Monarch
Is it possible that the timers are affected by switching between apps?
My tavern bonus timer frequently freezes up, and I get the impression this is caused by playing other games without closing down FoE 'properly ' first...
 

DeletedUser108851

I just had this happen today. I set all my Goods & Production buildings to do 8 hour tasks last night, yet only one showed as being completed this morning while the remaining buildings still showed they had about 7 hours remaining. When I logged in using my PC, they all showed as being completed.
 

DeletedUser104881

Thanks, that is helpful to know, we will try to replicate.