• Dear forum reader,
    To actively participate in our forum discussions or to start your own threads, in addition to your game account you need a forum account. You can
    REGISTER HERE!
    Please ensure a translation in to English is provided if your post is not in English and to respect your fellow players when posting.
  • We are looking for you!
    Always wanted to join our Support or Forum Team? We are looking for enthusiastic moderators!
    Take a look at our recruitment page for more information and how you can apply:
    Apply
  • Fall Event 2021


    Calling all Bakers! Read all about the Fall Event 2021 here!
  • Forum Contests

    Do you want to win great prizes? Don't forget to check out the current contest here.

Slowness issues since 1.27 update

Rosletyne

Warrant Officer
  • World: Brisgard
  • Browser and Version: Firefox 29.0.1
  • Overview of the bug: Since the 1.27 update I have been experiencing performance issues with the game. Part of them were caused by Hardware Acceleration as I reported previously, but there are more. The severity of the problems varies, the game is fine immediately after loading, but the longer it has been running, particularly if it has been in the background, the worse it becomes. Of course the game has always been like this, but the slowness got significantly worse after the update.

    I am fairly certain the root of the problem lies with city animations. The actual problems are with the user interface becoming slower, whether you click on buildings, menu options, scroll bars, or just about anything else. It should be noted that whenever you are doing any of those things, the city is always there in the background. There are more clues pointing to that conclusion too. I am able to polivate and fight large numbers of people without having to refresh, just as I did before the update. I have always had animations in other cities turned off, which is why I believe polivating has not gotten much worse. As for battles, selecting units can slow down, but on the battlefield where there are no city animations in the background I have never noticed any slowness at all.

    The most obvious clues pointing to city animations are, for one, that the issues are always worst in my main city on Brisgard, which is over twice as large as any of my other ones, and therefore has many more things going on at once. Also, I noticed that the issues are worst when the view is focused on the city center, with most of the screen filled by buildings. By comparison, when I zoomed in on an undeveloped corner of the city so that no buildings were visible, the issues disappeared almost entirely.
  • Screenshots: Not relevant to performance bugs.
  • How often this occurs: Almost all the time, with varying severity. The game is free of issues only for a short time after loading and starting Flash, and gets worse the longer it keeps running.
  • Urgency: High. The performance issues are very annoying, and I imagine they are turning players away from the game, particularly if their computers are not cutting edge.
  • Preventative Actions: Prevention is impossible. The issues can only be alleviated temporarily by refreshing and restarting Flash.
  • Summary: Since the 1.27 update the game has become significantly slower.
  • I have performed a quicksearch of the forums using a select few keywords relating to my bug to see if it has already been reported: Not reported yet, though there have been complaints of slowness in the discussion thread and elsewhere.
  • Have you tried fixing it by using methods listed in the thread pinned to the top of this forum: Yes, the issues keep coming back.
 

DeletedUser5355

Me too!
  • World: Brisgard
  • Browser and Version: Firefox 29.0.1
  • Overview of the bug: Since the 1.27 update I have been experiencing performance issues with the game. Part of them were caused by Hardware Acceleration as I reported previously, but there are more. The severity of the problems varies, the game is fine immediately after loading, but the longer it has been running, particularly if it has been in the background, the worse it becomes. Of course the game has always been like this, but the slowness got significantly worse after the update.

    I am fairly certain the root of the problem lies with city animations. The actual problems are with the user interface becoming slower, whether you click on buildings, menu options, scroll bars, or just about anything else. It should be noted that whenever you are doing any of those things, the city is always there in the background. There are more clues pointing to that conclusion too. I am able to polivate and fight large numbers of people without having to refresh, just as I did before the update. I have always had animations in other cities turned off, which is why I believe polivating has not gotten much worse. As for battles, selecting units can slow down, but on the battlefield where there are no city animations in the background I have never noticed any slowness at all.

    The most obvious clues pointing to city animations are, for one, that the issues are always worst in my main city on Brisgard, which is over twice as large as any of my other ones, and therefore has many more things going on at once. Also, I noticed that the issues are worst when the view is focused on the city center, with most of the screen filled by buildings. By comparison, when I zoomed in on an undeveloped corner of the city so that no buildings were visible, the issues disappeared almost entirely.
  • Screenshots: Not relevant to performance bugs.
  • How often this occurs: Almost all the time, with varying severity. The game is free of issues only for a short time after loading and starting Flash, and gets worse the longer it keeps running.
  • Urgency: High. The performance issues are very annoying, and I imagine they are turning players away from the game, particularly if their computers are not cutting edge.
  • Preventative Actions: Prevention is impossible. The issues can only be alleviated temporarily by refreshing and restarting Flash.
  • Summary: Since the 1.27 update the game has become significantly slower.
  • I have performed a quicksearch of the forums using a select few keywords relating to my bug to see if it has already been reported: Not reported yet, though there have been complaints of slowness in the discussion thread and elsewhere.
  • Have you tried fixing it by using methods listed in the thread pinned to the top of this forum: Yes, the issues keep coming back.
 

DeletedUser5355

In fact, the slowness is so bad that it could kill the game for me. Need more servers/bandwidth? Getting too popular/can't keep up? Whatever the reason, I don't want to waste my wastable time waiting for game lag. IS there anything we can do to help at our end? It would be great to turn off animations, maybe...
 

DeletedUser7719

Yea, turning off all animations would be something I could see coming ;)
 

DeletedUser7719

Clouds are supposed to automatically turn off if performance starts to slow, but it's not working for 3 of my computers at least half of the time.
 

DeletedUser97349

Whilst I don't contest that poor game performance and lagging is an issue which needs addressing (and is being addressed ;)) its not something I am able to pursue via our bug reporting system, therefore I will move this to Archive. It is being reviewed by the developers however.