• Dear forum reader,
    To actively participate in our forum discussions or to start your own threads, in addition to your game account you need a forum account. You can
    REGISTER HERE!
    Please ensure a translation in to English is provided if your post is not in English and to respect your fellow players when posting.
  • We are looking for you!
    Always wanted to join our Support or Forum Team? We are looking for enthusiastic moderators!
    Take a look at our recruitment page for more information and how you can apply:
    Apply
  • Forum Contests

    Don't forget to check out the current contests here.

Server down?

SirHarshOne

Private
Hello all,

I can log in at the main home page. Click onto play and the Inno logo screen shows then goes black. Then nothing. IS the SERVER DOWN?

SirHarshOne
 

DeletedUser110815

Seems like it is. I tried logging in via mobile platform but to no avail.

ETA: it works now for me on the PC platform. Huh.
 

DeletedUser110195

Considering your posts were separated by 3 months and that I haven't had this issue, I'm going to have to say it was something on your end, or so brief as to not be noticed by many.
 

DeletedUser110815

Possible. Strangely, all other worlds were working normally, just Brisgard kept giving the cannot login at the moment message when trying to sign in via the mobile platform.
 

DeletedUser110195

That could be why I didn't notice it, my Brisgard city is an alternate, I login to it rather erratically, sometimes multiple times a day, sometimes once every couple days.