• Dear forum reader,
    To actively participate in our forum discussions or to start your own threads, in addition to your game account, you need a forum account. You can
    REGISTER HERE!
    Please ensure a translation into English is provided if your post is not in English and to respect your fellow players when posting.
  • We are looking for you!
    Always wanted to join our Support or Forum Team? We are looking for enthusiastic moderators!
    Take a look at our recruitment page for more information and how you can apply:
    Apply
  • Forum Contests

    Won't you join us for out latest contest?
    You can check out the newest one here.
  • Jupiter Moon Era now taking passengers!


    Our latest era, Jupiter Moon is soon to be ready to explore! Read all about it here!
  • Archaeology Event 2022


    Explorers, it's time to dig your way into the Archaeology event! Read all about it here!

Mughal Empire settlement

kieranmcp

Private
Hi, I have just completed the third Mughal Empire settlement and have got the first upgrade kit. I wanted to build the temple but cannot find the level one building in my inventory. Does this mean that I have somehow deleted it or it wasn't awarded to me after completing the first settlement or something else? Has this happened to anyone else? Can anyone help?
 

Burpo

Sergeant
Hi, I have just completed the third Mughal Empire settlement and have got the first upgrade kit. I wanted to build the temple but cannot find the level one building in my inventory. Does this mean that I have somehow deleted it or it wasn't awarded to me after completing the first settlement or something else? Has this happened to anyone else? Can anyone help?
Hi Kieran, I have completed a few settlements too.
My lvl 1 is called "Mughal's Temple - lv. 1" and it is on page 9/11 of my inventory.
My upgrades are called "Mughal's Temple Upgrade Kit" and they are on page 5/11 of my inventory.
So the lvl 1 and the upgrades are separated by a few pages.

Hope this helps :)
 
Hi Kieran, I have completed a few settlements too.
My lvl 1 is called "Mughal's Temple - lv. 1" and it is on page 9/11 of my inventory.
My upgrades are called "Mughal's Temple Upgrade Kit" and they are on page 5/11 of my inventory.
So the lvl 1 and the upgrades are separated by a few pages.

Hope this helps :)
Lol. That depends on how many items you have in the inventory. :D
Just use the search feature in the inventory.
If you've deleted it by mistake send a ticket to support. They will give it back to you.
 

Burpo

Sergeant
Lol. That depends on how many items you have in the inventory. :D
Just use the search feature in the inventory.
If you've deleted it by mistake, send a ticket to support. They will give it back to you.
Very true, I was only assuming that the reason he couldn't find it was because he expected them to be together but they are not.
I have had the same problem with other lvl 1 buildings and their upgrades.
 

kieranmcp

Private
Thanks Guys for the replies, this is the first time using the forum so I wasn't sure I would get a reply.
I did a search and only the upgrade was present.
All's good now those great support guys sorted it :D
 

kieranmcp

Private
Hi Kieran, I have completed a few settlements too.
My lvl 1 is called "Mughal's Temple - lv. 1" and it is on page 9/11 of my inventory.
My upgrades are called "Mughal's Temple Upgrade Kit" and they are on page 5/11 of my inventory.
So the lvl 1 and the upgrades are separated by a few pages.

Hope this helps :)
Thanks for the reply, this is the first time using the forum so I wasn't sure I would get a reply.
I did a search and only the upgrade was present.
All's good now those great support guys sorted it :D
 

kieranmcp

Private
Very true, I was only assuming that the reason he couldn't find it was because he expected them to be together but they are not.
I have had the same problem with other lvl 1 buildings and their upgrades.
Thanks for the reply, this is the first time using the forum so I wasn't sure I would get a reply.
I did a search and only the upgrade was present.
All's good now those great support guys sorted it :D