• Dear forum reader,
    To actively participate in our forum discussions or to start your own threads, in addition to your game account you need a forum account. You can
    Please ensure a translation in to English is provided if your post is not in English and to respect your fellow players when posting.
  • We are looking for you!
    Always wanted to join our Support or Forum Team? We are looking for enthusiastic moderators!
    Take a look at our recruitment page for more information and how you can apply:
  • Fall Event 2021

    Calling all Bakers! Read all about the Fall Event 2021 here!
  • Forum Contests

    Do you want to win great prizes? Don't forget to check out the current contest here.

Mobile: Idle status on troop buildings doesn't update after fights


  • World: Noarsil
  • Browser and Version: Android app, v1.77.2
  • Overview of the bug: When you return to your city after a battle in which you have lost troops, the relevant troop buildings don't always update to 'idle' status to show that replacements can now be recruited. Then I log on again hours later and discover that the buildings have been standing idle when they could have been replacing my army :-(
  • Screenshots: None
  • How often this occurs: Frequently, but not always I think.
  • Urgency: Minor bug, but frustrating.
  • Preventative Actions: Logging out and logging in again after every battle will update building status reliably.
  • Summary: Troop building status does not update after battles on mobile app
  • I have performed a quicksearch of the forums using a select few keywords relating to my bug to see if it has already been reported: No.
  • Have you tried fixing it by using these methods?: Yes, and it's a feasible workaround


Are you still experiencing this issue with the latest version of the app (1.78)? Does it happen when you have a battle in a specific place (continent map, neighbors, GE)?


I've fought three guild expedition battles since the update (and surrendered in all three).
In the first two cases, the idle sign appeared above the troop buildings when I returned to my city after the battle. In the one I tried just now, it didn't. I checked on some buildings manually and found vacant troop spaces, then logged out and in again and promptly found another one that I'd missed :-(


This occurred to me in fel unsure if rectified as I now have full troops in my troop buildings


This is still happening on a frequent (but not inevitable) basis. I just came back after losing troops on a guild expedition and discovered that my troop production buildings were now sitting idle without any indication.