• Dear forum reader,
    To actively participate in our forum discussions or to start your own threads, in addition to your game account you need a forum account. You can
    REGISTER HERE!
    Please ensure a translation in to English is provided if your post is not in English and to respect your fellow players when posting.
  • We are looking for you!
    Always wanted to join our Support or Forum Team? We are looking for enthusiastic moderators!
    Take a look at our recruitment page for more information and how you can apply:
    Apply
  • Forum Contests

    Don't forget to check out the current contests here.

Login Issue

DeletedUser17143

  • World: EN server
  • Browser and Version: Tried with Google Chrome, IE and Microsoft Edge
  • Overview of the bug: When logging in, it brings up "404 Not found" where I should click Play or add my username and password. I've cleared my Cache with no change.
  • Screenshots:

  • How often this occurs: First time, but also happens on Beta server.
  • Urgency: Very Urgent.
  • Preventative Actions: None
  • Summary: 404 Not found
  • I have performed a quicksearch of the forums using a select few keywords relating to my bug to see if it has already been reported: Yes
 

DeletedUser16026

I have no issue with it after clearing cache, but on Firefox. Particularly after entering incognito/private browsing mode.
 

DeletedUser108489

have been unable to log in since the update. Have contacted support but up till now no help whatsoever. Have done all they asked of me changed password etc cleared cache but nothing it seems gets me back in. Now I can't even get in contact with them. They asked for a screen shot which i have done but unable to send. I am running windows explorer, Not only me it seems i have friends in other countries that can't get in also. I wish to state I have spent over 200 pounds which i intend to recuperate due to support failures. It is a game i enjoyed playing and hope to play again when sorted
 

DeletedUser108489

As usual no reply from support. Having to play clash of kings hope i get better support from there, But will return if i can ever getback in here again
 

DeletedUser108489

What does it take to get a reply. No contact by e mail or on here.
 

DeletedUser97166

So to recap you have
1. cleared cache
2. tried both firefox and chrome
3. checked using another device to check it isn't a setting on your computer.

You've done all that and still not working at all?