• Dear forum reader,
    To actively participate in our forum discussions or to start your own threads, in addition to your game account, you need a forum account. You can
    REGISTER HERE!
    Please ensure a translation into English is provided if your post is not in English and to respect your fellow players when posting.
  • We are looking for you!
    Always wanted to join our Support or Forum Team? We are looking for enthusiastic moderators!
    Take a look at our recruitment page for more information and how you can apply:
    Apply
  • Forum Contests

    Won't you join us for out latest contest?
    You can check out the newest one here.
  • Jupiter Moon Era now taking passengers!


    Our latest era, Jupiter Moon is soon to be ready to explore! Read all about it here!

Fixed: Loading issue

Status
Not open for further replies.

Clint Black

Private
STILL unable to load the game, some 10 hours after it went offline for an update!!!! Gggrrrrr It loads up to 48% or sometimes 51% but no further..
 

hawknz

Corporal
Sorry to hear!

The devs have made another change, Can you wait a few minutes then do the cache and cookie clear and reload your browser again? System admins have said it could take a bit for some as we're redirecting providers but for most should see an immediate improvement
 

Clint Black

Private
Thank you hawknz - that indeed did resolve the issue - I very much appreciate the advice & quick response: I should have written back quicker, but I've been a little busy catching up!!
 

Shabooboo

Private
Here's how to do that on Chrome:

F12 to bring up Developer Tools
Right click on Refresh button
Select 'Empty Cache and Hard Reload'
 

Tulac

Private
Went on this morning and still no luck with loading. Then went into browser settings (Browser - Edge) and cleared browser date for last 7 days. Now loading.
 

Mandolyn

Private
Here's how to do that on Chrome:

F12 to bring up Developer Tools
Right click on Refresh button
Select 'Empty Cache and Hard Reload'
Thanks Shabooboo, that worked for me when all the other ways didn't. Now loading without issues.
 
Status
Not open for further replies.
Top