• Dear forum reader,
    To actively participate in our forum discussions or to start your own threads, in addition to your game account you need a forum account. You can
    REGISTER HERE!
    Please ensure a translation in to English is provided if your post is not in English and to respect your fellow players when posting.
  • We are looking for you!
    Always wanted to join our Support or Forum Team? We are looking for enthusiastic moderators!
    Take a look at our recruitment page for more information and how you can apply:
    Apply
  • Forum Contests

    Don't forget to check out the current contests here.

In PE but game thinks im in Modern Era

DeletedUser100618

  • World: Houndsmoor
  • Browser and Version:
  • Overview of the bug: I'm in Progressive Era, I've researched everything but not yet unlocked Modern Era, and yet the quests are acting like I'm already in Modern Era (construct 2 buildings from your previous Era.. but I have to make 2 from PE) and my St Marks has now started giving double the good from several eras ago - as it would if I had gone into ME rather than Prog Era goods
  • Screenshots:
  • How often this occurs:
  • Urgency:
  • Preventative Actions:
  • Summary:
  • I have performed a quicksearch of the forums using a select few keywords relating to my bug to see if it has already been reported:
  • Have you tried fixing it by using methods listed in the thread pinned to the top of this forum:
 
Last edited by a moderator:

DeletedUser97349

As Thanatos said, this is best investigated via ticket as we cannot post details of your account on the forum. As such I'll move this to archive.