• Dear forum reader,
    To actively participate in our forum discussions or to start your own threads, in addition to your game account you need a forum account. You can
    REGISTER HERE!
    Please ensure a translation in to English is provided if your post is not in English and to respect your fellow players when posting.
  • We are looking for you!
    Always wanted to join our Support or Forum Team? We are looking for enthusiastic moderators!
    Take a look at our recruitment page for more information and how you can apply:
    Apply
  • Forum Contests

    Don't forget to check out the current contests here.

General Dee was really President Cartwright after all!

Surge

Brigadier-General
  • World: Jaims
  • Browser and Version: Latest Chrome
  • Overview of the bug: So apparently the province Garrincton needs to be owned by General Dee, but the problem is that it's owned by President Cartwright (his portrait is wrong) and it displays his peaceful text, since I never attacked him but I attacked General Dee. The quests also imply that the conflict is still going on with General Dee (the final battle is coming, etc.).
  • Screenshots:
  • How often this occurs: Always
  • Urgency: Kind of breaks the storyline when I have to backstab my ally.
  • Preventative Actions: None.
  • Summary: Wrong people over a province.
  • I have performed a quicksearch of the forums using a select few keywords relating to my bug to see if it has already been reported: Yeah.
  • Have you tried fixing it by using methods listed in the thread pinned to the top of this forum: Nothing worked.

EDIT: For whatever reason, the issue fixed itself. Somehow. I refreshed before but it didn't work. Now it's just back.
 
Last edited:

DeletedUser97349

As this seems to have corrected itself it seems to be a one off glitch, so I will move it to archive. If however it reoccurs, please post again and we can investigate further.