Format Buttons unresponsive when editing guild forum posts.

Bartimaeus46

Second Lieutenant
  • World: All.
  • Browser and Version: Opera/12.02 & Opera/12.12 (Game version 0.24.11762)
  • Overview of the bug: When editing a post in the in-game guild forums, the format buttons ([B][I][U] etc) become unresponsive. As can be seen by the way the colour of a highlight turns white, clicking the buttons perform the same function as clicking outside the textbox would.

    How to reproduce:
    Make a post as normal.
    Click to edit post.
    Highlight text you wish to make bold, underlined etc.
    Click the corresponding button.
  • Screenshots:
  • How often this occurs: Every time. (In affected browsers)
  • Urgency: Not urgent.
  • Preventative Actions: Make sure you post perfectly first time. or. Manually add BB codes tags.
  • Summary: When editing a post, the format buttons are unresponsive, New posts are not affected.
  • I have performed a quicksearch of the forums using a select few keywords relating to my bug to see if it has already been reported: Yes
  • Have you tried fixing it by using these methods?: Yes

Tested Browsers:
  • Opera Version/12.02 - Affected
  • Opera Version/12.12 - Affected
  • Chrome/24.0.1312.52 - Not Affected
  • Firexox/18.01 - Not Affected
  • MSIE/9.0 - Conflicting evidence
 
Last edited:

ddrd1981

These may help, I had exactly the same issue as yourself;

colour codes etc....png

Not all colour codes listed but at least the ones that I use most regularly.
~ddrd1981
 
Last edited by a moderator:

davidb3

I have previously reported this as a bug with IE9 and Win7x64, but my bug report post seems to have disappeared? :(
Just to confirm, the issue occurs only when EDITing a guild forum posting; the icons work fine when CREATING a new forum post.
 

Lodroth

I have tested it on MSIE9 and -64bit, both Win7. It works fine on there.
Created a new post with the buttons, worked.
Edited the new post with the buttons, worked.
Edited an old post with the buttons, worked.

Not sure when you created your bug report david, but it might've been outdated and therefore removed.
 

davidb3

Hi Lodroth,
I found my bug report (posted January 14) - you and Mutzena were unable to replicate the problem at the time with other browsers - have a look at this thread (which was incorrectly marked as "Cannot reproduce"). http://forum.en.forgeofempires.com/showthread.php?11062-Unable-to-bold-or-change-colors-when-editing-Guild-Forum

Note: in my former IT support job, I learned that it was very important to test with the same rights as the users experiencing the problem - make sure you don't have any sort of admin rights enabled when testing this issue. (I have moderator and leader rights in the guild forums on at least one world where I have this issue, but do not run with local admin rights on my Win7 PC.) Unfortunately it sounds like this problem is just something that shows up for some people and not others. Weird.
That said, it could easily depend on the flash/shockwave version or something - let me know if you need anything else checked (although they should all be up to date).

And yes, I just tested again and confirmed that this issue is still occurring for me on Win7 x64 IE9 (update 9.0.12), i.e. after the 0.25 update. I have tried and confirmed this behaviour with both "IE9" and "IE9 64-bit" on my Win7x64 PC.
...
Update: confirmed same bug behaviour for me with IE9 on Vista SP2 (32-bit).
 
Last edited by a moderator:

Lodroth

With which rights did you confirm that?
Currently I have all the rights, from Founder to Trusted.
 

davidb3

Hi Lodroth, never mind, ignore the rights issue, it's probably something else. I have tested this issue and it is consistent for me, whether I have local admin or only user rights on my PC, Vista or Win7, and only user or full regular (leader/moderator/trusted etc. but not Founder) rights within the game. (Users are allowed to edit posts that they created in the guild forum).

The only thing I can't test / don't know, is if you and Mutzena have any other special rights within the FoE game, due to your being Moderators. Obviously, Bartimaeus46 seems to see the issue as well though. What might be interesting is if you could test with Opera, to see if you see the problem or not? This would help isolate if it's a userid-based or browser-based issue...
 

Pendragon

The only thing I can't test / don't know, is if you and Mutzena have any other special rights within the FoE game, due to your being Moderators.
Moderators are exactly the same as any other player ingame - they do not have other or more rights. So that can't be it then.