• Dear forum reader,
    To actively participate in our forum discussions or to start your own threads, in addition to your game account you need a forum account. You can
    REGISTER HERE!
    Please ensure a translation in to English is provided if your post is not in English and to respect your fellow players when posting.
  • We are looking for you!
    Always wanted to join our Support or Forum Team? We are looking for enthusiastic moderators!
    Take a look at our recruitment page for more information and how you can apply:
    Apply
  • Forum Contests

    Don't forget to check out the current contests here.

Not a Bug: Forge points

QueenOfHearts

Logged in today and had one forge point to use, then i got the "internal error" it logged out and then in again and the forge point was gone. Now i have none. :(

  • Bronze age:
  • Safari 5.1.1:
  • Overview of the bug:
  • No, just says no forge points:
  • one time:
  • naa, but it is kind of annoying:
  • Preventative Actions - logged out and in again - nothing happened
  • Summary:
  • I have performed a quicksearch of the forums using a select few keywords relating to my bug to see if it has already been reported - Yes this time i remembered, and could not find anything:
  • Have you tried fixing it by using these methods?:
yes.
 

HaekelHansi

This has happened to me too, when using forgepoints, the game gave me an internal error. However, after a login and checking, the forgepoints were added to my research, so no harm done.