• Dear forum reader,
    To actively participate in our forum discussions or to start your own threads, in addition to your game account you need a forum account. You can
    REGISTER HERE!
    Please ensure a translation in to English is provided if your post is not in English and to respect your fellow players when posting.
  • We are looking for you!
    Always wanted to join our Support or Forum Team? We are looking for enthusiastic moderators!
    Take a look at our recruitment page for more information and how you can apply:
    Apply
  • Fall Event 2021


    Calling all Bakers! Read all about the Fall Event 2021 here!
  • Forum Contests

    Do you want to win great prizes? Don't forget to check out the current contest here.

Cirgard not loading

Drama-Queen

Corporal
I am only able to get onto "A" world. Both B & C are not loading.
Anyone else having problem login into multiple worlds??
 

DeletedUser4089

What exactly is happening? What screen do you get stuck at? What does it say? Does it give an error?

It's really hard to help without details.
 

LinkR

I am having some trouble too. Seems to have been going on all day. It either loads veeeery slowly, or it just times out and shoots me back to the server select. At times I can get back in, but otherwise it just says I can not log into that server for a bit. I am guessing the servers are just under some stress and needs a tune up.
 

DeletedUser276

Have you tried hard refreshing (ctrl + F5) and closing other tabs and computer operations?
 

LinkR

Yes. I have rebooted my PC and restarted my router. My guild is also talking about it. The A server seems fine, but C seems to be server side. I hear B is having the same problem. I can get in from time to time I said, but within minutes after trying to load a trade or what have you, it ends up booting me to the servers and not letting me into B or C.
 

delboy281

Same as, all i get is a blank screen. rebooted pc and been refreshing to no avail.