• Dear forum reader,
    To actively participate in our forum discussions or to start your own threads, in addition to your game account you need a forum account. You can
    REGISTER HERE!
    Please ensure a translation in to English is provided if your post is not in English and to respect your fellow players when posting.
  • We are looking for you!
    Always wanted to join our Support or Forum Team? We are looking for enthusiastic moderators!
    Take a look at our recruitment page for more information and how you can apply:
    Apply
  • Forum Contests

    Don't forget to check out the current contests here.

Can not enter Guild Battleground or Expedition

Sir Bolja

Private
When trying to go into either GB or GE I always receive an error message - Sorry an unexpected error has occurred - and the the game "hang up" and I have to restart again.
Using Firefox browser ver 84.0.1 (64-bit) and it is up to date. Used Chrome before but had problem after update of chrome to ver 86.xxx and 87.xxx
It was working before in Firefox but have had this problem every time I tried to get there
Rest of the game is working and I have no problem reaching other websites

Have tried to reinstall Firefox and also an older version of Chrome ver. 84.xxx
Cleared cashe and so on
Have no possibility with other computer but have tried another WiFi- network but same problem

World is Odhrovar
Time zone GMT +8 (Manila, Philippines)
My URL https://en14.forgeofempires.com/game/index?ref=fac_nn_nn_2785_4319_40982_2022-29736
/Christer Allvin
christer.allvin@indoscand.org
 
Last edited:

Sir Bolja

Private
Still the same - what can I do to resolve this problem...? As it is I am unable to assist my Guild
All the best
/Sir Bolja