• Dear forum reader,
    To actively participate in our forum discussions or to start your own threads, in addition to your game account you need a forum account. You can
    REGISTER HERE!
    Please ensure a translation in to English is provided if your post is not in English and to respect your fellow players when posting.
  • We are looking for you!
    Always wanted to join our Support or Forum Team? We are looking for enthusiastic moderators!
    Take a look at our recruitment page for more information and how you can apply:
    Apply
  • Fall Event 2021


    Calling all Bakers! Read all about the Fall Event 2021 here!
  • Forum Contests

    Do you want to win great prizes? Don't forget to check out the current contest here.

New Bug: Black screen entering O or MK worlds on PC

Bagoas

Private
Since a few hours ago, I am getting a black screen when I try to log in to O world or MK world on my PC. I select the world, the Inno flash comes up briefly then the screen stays black instead of loading page.

I also play in N world, and can get in to that OK.

I have the same problem with Chrome and Firefox, but Edge (I have Windows 10) is OK. Have tried clearing cache and rebooting PC but no benefit. iPad is OK. (Edge has its own problems - memory problems with Forge causes crash in less than 30 minutes)

Other players have a similar problem with with different world. Cannot get in to N world but can get into O.
Speculating the pattern is we can get in to the last world we were on before the problem started.